安全公告
当前位置: 首页>>网络安全>>安全公告>>正文
关于Spring远程命令执行漏洞的安全公告
2022-03-30     (点击: )

大工网安告[2022]014号

一、情况分析

Java Spring框架被发现存在远程命令执行漏洞,未经身份验证的攻击者可以使用该漏洞进行远程代码执行,获取服务控制权,目前漏洞相关利用poc已经小范围公开,后续可能会造成大范围传播,造成严重危害。Spring是一款目前主流的Java EE轻量级开源框架,为JavaEE应用提供多方面的解决方案,用于简化企业级应用的开发。

漏洞影响排查方法

JDK版本号排查:

若JDK版本号≤8,则不受影响。

Spring框架使用情况排查:

1、若业务系统项目以war包形式部署,按如下步骤判断:

  • 解压war包:将war文件的后缀修改成.zip,解压zip文件。

  • 在解压缩目录下搜索是否存在spring-beans-*.jar格式的jar文件(如spring-beans-5.3.16.jar),如存在则说明业务系统使用了spring框架进行开发。

  • 若spring-beans-*.jar 文件不存在,则在解压缩目录下搜索CachedIntrospectionResuLts.class 文件是否存在,如存在则说明业务系统使用了Spring框架开发。

2、若业务系统项目以jar包形式直接独立运行:

  • 解压jar包:将jar文件的后缀修改成.zip,解压zip文件。

  • 。在解压缩目录下搜索是否存在spring-beans-*.jar 格式的jar文件(例如spring-beans-5.3.16.jar),如存在则说明业务系统使用了spring框架进行开发。

  • 如果spring-beans-*.jar 文件不存在,则在解压缩目录下搜索CachedIntrospectionResuLts.class 文件是否存在,如存在则说明业务系统使用了spring框架进行开发。

二、影响版本

同时满足如下条件可确定受此漏洞影响:

  • JDK版本号在9及以上的

  • 使用了spring框架或衍生框架

三、处置建议

将 Spring 框架升级到 5.3.17 版本,官方已修复!

还可采用如下的临时方案进行防护,并及时关注官方补丁发布情况。

需同时按以下两个步骤进行漏涧的临时修复:

  • 在应用中全局搜索@InitBinder注解,看看方法体内是否调用dataBinder.setDisallowedFields方法,如果发现此代码片段的引入,则在原来的黑名单中,添加{"class.*","Class. *","*. class.*", "*.Class.*"}。(注:如果此代码片段使用较多,需要每个地方都追加)

  • 在应用系统的项目包下新建以下全局类,并保证这个类被Spring 加载到(推荐在Controller 所在的包中添加)。完成类添加后,需对项目进行重新编译打包和功能验证测试,并重新发布项目。